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Introduction

What are we creating?

Welcome to the Creation Crate 2.0! You’ve taken your first step in learning how to build elec-
tronics and write code! We have put a lot of thought and effort in bringing you some fun and 
engaging projects. We have upgraded and added many new components and have redesigned 
our packaging to become part of your project! 
 
Once you’re done with your project, we would love for you to show us how it turned out and 
leave us some comments about what you liked, tips for others, and how we could further im-
prove.

Today, we're making a mood lamp! This lamp changes colors and only turns on when it's dark.

instagram.com/creationcrate

facebook.com/creationcrate

twitter.com/creationcrate
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Parts List

Other things you'll need

- Tape
- A sharp pencil or something to poke holes in the box.
- X-ACTO/ hobby knife* – not required, but can be helpful when separating the perforations in 
the cardboard. Use only with adult supervision. 
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x2

x1

x1

x2

x1

x10

x2

x1 x1

x5

x3

x1

Breadboard

Green LED

2.2k Ohm 
Resistor

Blue LED

USB Cable

Uno R3 
Microcontroller

20cm Male-
to-Female 

Jumper Wires

Paper lanternLight 
Dependent 

Resistor (LDR)

10cm Male-to-
Male Jumper 

Wires

Double Sided 
Tape Squares

Red LED

Power Supply
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What will we learn making this project?
We will learn about electronics:
- What is a microcontroller?
- What is a breadboard?
- What is a resistor?

And about programming:
- What is code? (and why do we need semicolons)
- What are variables?
- What is an IF statement used for?
- What is Pulse Width Modulation (PWM)?

Getting Started with Electronics

Getting Started with Arduino (hardware)

Getting Started with Coding

Plus, an extensive Component Video Library

Password: xxxxxx
If you ever get stuck, go to:  www.creationcrate.com/mood-lamp-redux 

TIP: Before you get started on your first project, depending on your ex-
perience level, you might want to check out some of our Getting Started 
videos available on our website https://www.creationcrate.com
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Electronics Basics:
What is a Microcontroller?

What is a Jumper Wire?

In this kit, we will be programming the UNO R3, Arduino-compat-
ible microcontroller to turn LEDs on and off based on the sensor 
reading from the Light Dependent Resistor. A microcontroller is a 
tiny computer that runs programming code. Instead of a screen 
and a keyboard, there are multiple input and output “pins” that can 
read the value of buttons and sensors or turn lights and motors on 
and off. In this project, you’ll learn how to write the code to control 
these pins.

These wires are used to connect all of the components to the 
breadboard and the microcontroller.  Jumper wires are great 
because you don’t have to solder or twist them together, are not 
permanent, and can be moved around as you experiment and 
build your circuit

TIP: New to electrical circuits? You may want to watch the Getting Started with 
Electronics video in our Online Classroom.  www.creationcrate.com/classroom 

What is a Resistor?
A resistor does exactly what it sounds like: it resists the flow of 
electricity. You can think of electricity running through wires as water 
running through a hose. If you form a kink in the hose, the water will 
run slower. 
Resistors have different values, measured in Ohms. The more Ohms, 
the less electricity can pass through it. To tell the difference between 
the values, resistors have color bands on the side. In this project, 
we’ll use a 2.2k Ohm resistor, which has a color code of Red Red 
Red.
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What is an LED?
An LED is a Light Emitting Diode.  As a diode, electricity can only 
flow in one direction.  Therefore it is important to connect the 
leads properly.  The longer lead is the anode, which is the positive 
(+) lead and the shorter one is the cathode, or negative (-).  Allow-
ing too much current to flow through the LED will burn it out, so 
a resistor is usually placed in the circuit. In this project we are not 
using a resistor with the LED because we are using Pulse Width 
Modulation (more on that later), so take care not to connect the 
LED directly to the 5V power.

Cathode (-)
Anode (+)

What is a breadboard?
We will be using what’s known as a breadboard to connect all 
the wires and components together. The breadboard has a series 
of holes that you can insert wires and components into. Running 
across the top and bottom are the power rails. The holes along the 
blue dotted line are all connected, and the holes across the red 
dotted line are all connected:

1

(+)
(-)

F
G

H
I

J

5 10 15 20 25 30
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We will need to prepare the project box first.  You will need to poke a few holes (where 
you see an X) using a sharp pencil or something similar.  These can be fairly small.  Then, 
pop out the perforated cutouts (where you see the dotted lines).

Hardware Assembly

We will use these to attach the power wires so that we can power all the components without 
needing to have wires stretching to each component. Usually, we connect the positive voltage 
to the red power rail, and the negative voltage to the blue rail. The rest of the holes are connect-
ed down each column, with a gap in the middle, like this:

By plugging two wires together in the same column, they become connected.

1
F

G
H

I
J

5 10

Energetic

Calm

Smart

Creative

LDR

BuildLearn Code

1
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Now let's connect the power from the microcontroller to the breadboard.  We will use 
Jumper Wires to connect the 5V and the GND pins from the microcontroller to the bread-
board.

Attach the Light Dependent Resistor (LDR) by poking the leads through the holes you 
poked in the box and then attach a 30cm female to male jumper wire to each.  Remember, 
wire color doesn’t matter.

Energetic

Calm

Smart

Creative

LDR

3

4

Attach the microcontroller and the breadboard to the inside of the box using two of the 
double-sided adhesive squares.

2

1

(+)
(-)

F
G

H
I

J

5 10 15 20 25 30

(Bottom of the Inside)
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Next we will attach the LEDs.  You can use one or both LEDs of each color.  You will need 
two 30cm female to male jumper wires.  One is for the anode(+) and one for the cath-
ode(-).  Then push the male leads through the hole you punched out in the top of the box.
TIP: If you are using both LEDs, take care to ensure that the anode and cathode leads are 
not touching each other. 

Wire the LDR, resistor, and microcontroller together.  One of the leads from the LDR will go 
in the same column as the resistor and the other will go to ground.  Using a 10cm jumper, 
connect the other LDR lead to the positive rail.  The last wire will go from A0 on the UNO 
to the column that has both the LDR and 2.2k Ω resistor in it.

Energetic

Calm

Smart

Creative

LDR

5

6
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Awesome!  You built the hardware and it looks great! ...but it doesn’t do anything yet. 

Now What?

In order for the Mood Lamp to run, you need to program it!
Microcontrollers are a combination of hardware and the coded instructions. You can’t have a 
working project with just one half.

Once all of the wires have been pushed through the box and the LEDs are secured, con-
nect the leads to the breadboard and the microcontroller.

When you are done with the code, you can use the hole in the back panel for the A/C power. 
(See  step  10  after  you  are  done  typing  in  the  code) 

Time to assemble the paper lantern and place it over the LEDs.

7

8

9
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First we need to download the Integrated Development Environment (IDE).  This is the applica-
tion you will use to type in all of your code.  Remember, the computer only ‘understands’ the on/
off states of the transistors in its processor.  The IDE allows us humans to use words that make 
sense to us when we write our code, and then compiles the information and translates it to 
something the computer can use.  

You have two options for the IDE.  You can download the software onto your PC or Mac or you 
can use a web-based version on the Arduino website.  The advantage to using the downloaded 
version is that you can use it even when you are not connected to the Internet.  On the other 
hand, the web-based version allows you to save your Sketch (program) in the cloud and access 
it from multiple computers.  If you are using a Chromebook, you will need to use this version.

1. Go to https://www.arduino.cc/en/Main/Software
2. Download & install the Arduino Software (IDE)
3. Open the Arduino program and navigate to “File > New”
4. Delete all of the existing text/code. We’ll add this back later.
5. Navigate to “File > Save” and save the sketch as “Mood_Lamp_Redux”  (Sketch names can-
not have spaces)
6. Turn the page and start programming!
7. If you are using a Mac, go to https://creationcrate.com/mood-lamp-redux (password: JTGA18) 
and download the driver. Skip if you have done this in a previous project.

Code is a set of instructions that the microcontroller will do. We have to tell the microcontroller 
when an instruction is done, and the next one should be started. For the most part, every line of 
code is a different instruction. We use semicolons “;” to separate these lines of code, and almost 
every line ends with one. 

A variable is a placeholder for a number. For example, say we make a variable called “x”.
To make a variable that holds an integer (int), we write:

int x;

If we set x equal to 6 and tell the microcontroller to read x, it will tell us the value of x is 6. 
To set x equal to 6 we write:

x = 6;

How do we start programming?

What is code?

What is a variable?

TIP: New to writing code? You may want to watch the Getting Started with 
Coding video in our Online Classroom.  www.creationcrate.com/classroom 

Programming Basics:
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We can do math on these variables, so for instance we can set x equal to itself plus 3;

x = x + 3;

The value of x is now 9.

Sometimes the microcontroller will have to make a decision based on the value of certain vari-
ables or sensor readings. We can have code that only runs when a specific condition is true.
To make an if statement that sets x to zero, only if x is greater than 5, we can write:

If ( x > 5)
{
  x = 0;
}

We can also have code that runs when a condition is not true, like this:

If ( x > 5)
{
  x = 0;
}
else  //’else’ is kind of like saying, “otherwise”
{
  x = x + 1
}

When you start the Arduino IDE, your code will automatically have “functions” called setup() and 
loop(). Anything inside the curly brackets { } after the line void setup() will run once when you 
turn on your Uno R3. Anything inside the curly brackets { } after the line void loop() will run again 
and again until you turn off your UNO R3.

Note: Each line of text here is a line of code. They run one after another. Also, most lines must 
end with a semicolon ( ; ). Lines that start with “//” are called comments which are just explana-
tions and will not be executed. You don’t need to type them out. In fact, it’s encouraged to write 
your own comments, it will help you (and others) understand the code better when you go back 
to it later.

Let’s begin!

What is an if statement?

What is setup() and loop()?

Program
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/*  Creation Crate Mood Lamp
This lamp smoothly cycles through a colour spectrum. It only turns on when its surround-
ings are dark. We will use the SINE function (SIN) and a variable to cycle the light intensity 
of each color from low to high and back.

Step 1: Define the Libraries and Input User Defined Variables
Think of variables like containers - they’re used to store information. */

#include <SoftwareSerial.h>
//  This value controls how fast the mood lamp runs. You can use any whole number.
int pulseSpeed = 5;

//  These are the pins we are using with the UNO R3 (Arduino-compatible). You can 
//  see the numbers on the board itself.
int ldrPin = 0;       // LDR in Analog Input 0 to read the surrounding light.
int redLed = 11;   // red LED in Digital Pin 11.
int greenLed = 10;  // green LED in Digital Pin 10.
int blueLed = 9;    // blue LED in DIgital Pin 9.

// This variable stores the value of the light in the room.
int ambientLight; 

// This variable controls the brightness of the lamp (2-255).
int power = 120;

//  This is an ‘[array]’, used to store the values of the Red, RGB[0]; Blue, RGB[1] & Green, 
RGB[2] LEDs.
float RGB[3];

/* We are using the value of 180/PI a lot in the main loop, so we will calculate it once 
here in the setup and store it in CommonMathVariable. Note: it's PI (eye), not P1 (one) */
float CommonMathVariable = 180/PI;

//  Step 2: Create Setup
//  void setup() runs once when the program starts.  Here it creates the initial values for our 
LEDs.
void setup () {
  
/*This can be used when troubleshooting the code.  We can 'print' values to Serial Monitor 
so we can determine if the code is executing all the way through, what values are register-
ing, etc.*/
Serial.begin(9600);

// This tells the UNO R3 to send data out to the LEDs.
pinMode (redLed,OUTPUT);
pinMode (greenLed,OUTPUT);
pinMode (blueLed,OUTPUT);

1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.
12.
13.
14.
15.
16.
17.
18.
19.
20.
21.
22.
23.
24.
25.
26.
27.
28.
29.
30.
31.
32.
33.
34.
35.
36.

37.
38.
39.

40.
41.
42.
43.
44.
45.
46.
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//  This sets all the outputs(LEDs) to LOW(OFF), so that they do not turn on during startup.
digitalWrite (redLed,LOW);
digitalWrite (greenLed,LOW);
digitalWrite (blueLed,LOW);

}   // Opening brackets must be accompanied by closing brackets.

/* Step 3: Create Main Loop
The previous sections set everything up. Here is where we put it to work! This part of the 
program is a ‘loop’. It repeats over and over. Each time we make a small change to the LEDs’ 
brightness – creating smooth colour transitions. */

void loop () {

//This for command executes as long as the condition x < PI is true
for (float x = 0; x < PI; x = x + 0.00005) {  

  //The equations below are used to make the LEDs fade in and out at different intervals
  RGB[0] = power * sin(x  * (CommonMathVariable));                // Red LED.
  RGB[1] = power * sin((x + PI/2) * (CommonMathVariable));        // Green LED.
  RGB[2] = power * sin((x + (PI * 2/3)) * (CommonMathVariable));  // Blue LED.

  // This is reading the light in the room and storing it as a number.
  ambientLight = analogRead(ldrPin);

  // This ‘if statement’ will make the lamp turn on when it is dark. Less light = greater resis-
tance.
  if (ambientLight > 700) {
 
    // This shuts the LED off for a bit once the pulse is less than 20 to mix the other 2 colors.
    if (abs (RGB[0])<10) {
     RGB[0] = 0;
    }
    if (abs (RGB[1])<10) {
      RGB[1] = 0;
    }
    if (abs (RGB[2])<10) {
      RGB[2] = 0;
    }

    // This section varies the delay, When one colour is dim, the delay is longer.
    // This keeps the that colour dim for a bit longer to let the other two mix.

    if (abs (RGB[0]) < 40) {   
      delay (15 * pulseSpeed);
    }

47.
48.
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    else if (abs (RGB[1]) < 20) {   // ’else if’ means only one of these conditions can execute at 
a time.
      delay (10 * pulseSpeed);
    }
    else if (abs (RGB[2]) < 30) {
      delay (10 * pulseSpeed);
    }   

    //  This blank ‘else statement’ is a fail-safe mechanism. It instructs the program to do 
nothing 
    //  if the conditions above do not activate. This prevents the program from generating 
errors when calculating delays.
    else {}

    //  These ‘analogWrite’ statements assign the Absolute Value(abs) of the result we calcu-
lated above to the LED, changing its brightness
    analogWrite (redLed,abs (RGB[0]));
    analogWrite (greenLed,abs (RGB[1]));
    analogWrite (blueLed,abs (RGB[2]));
 }   // Don’t forget to close this ‘if statement’ with a bracket!

  //  This ‘else statement’ will only activate if the ‘if statement’ above does not (ie. If it is 'too 
bright' in the room). The LEDs are set back to LOW(OFF). 
  else {
    digitalWrite (redLed,LOW);
    digitalWrite (greenLed,LOW);
    digitalWrite (blueLed,LOW);
   }

  }   // Closes the 'for' command
}     // Don’t forget to close the void loop() with these brackets!

93.
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Almost there!

Hardware Assembly Continued

Now that you’ve entered the code, it’s time to see if it works!

1. Connect your Uno R3 board to your computer with the USB cable provided.
2. Navigate to ‘Tools > Port’ and select the port connected to your Uno R3. (If you have trouble 
finding the right port, try disconnecting other USB devices).
3. Navigate to ‘Tools > Board’ and select “Arduino/Genuino Uno”
4. Navigate to ‘Sketch > Upload’. You should see this at the bottom:

(If the program doesn’t upload and you see error messages, don’t worry! Errors are very com-
mon when coding- I’d be more surprised if you didn’t have any! See the next page for possible 
solutions).
5. Your project should now be working!
6. Now see if you can solve the exercises on page 20 to test your new skills and understanding 
of the project.

10.  Switch  to  AC  power  

A.  Remove  the  blue  USB  cable.
B.  Cut  out  the  hole  in  the  back  of  the  box.
C.  Fit  the  power  adapter  plug  through  it.
D.  Plug  it  into  the  UNO  R3  inside  the  box.

BuildLearn Code
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Troubleshooting
Programming errors

Typos - The words have to be exacty! MAkure sure your code matches the code in this 
booklet. Note: Letters are case-sensitive.

Missing ';' - Any time you write a line of code, it has to end with a ';' (semicolon). The only 
exceptions in this code are lines that start with 'void', 'if', 'else', or 'for'.

Missing/extra brackets - Any time you use an opening bracket '(' or '{', you must have a 
closing bracket to match it ')' or '}'. Having too many brackets will also create errors. Lastly, 
make sure these are placed correctly!

These are the most common programming errors:

1

2

3
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If your code looks okay but your project still isn’t working, there may be something wrong with 
your wiring!  Here are some common errors:

The most common error is to reverse the LED leads.  Ensure that the shorter lead is con-
nected to the negative (blue) and the longer lead is connected to the positive (red) rail on 
the breadboard.

Make sure you have the red power rail connected to 5V and the blue power rail con-
nected to GND from your UNO R3. Also make sure all the components are going to the 
correct rails.

Make sure all the wires that are supposed to be connected are in the same column.

TIP: Instead of having to disconnect the jumper wires to see 
which is longer, if you look closely inside the LED you can see 
that the large tip is the positive and small tip is the negative. 

Hardware errors

1

2 3

1

2

3

(-)(+)
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Move the 2.2k Ohm resistor to another spot on the board without moving the Light Dependent 
Resistor, without changing how the project runs! Hint: You will have to use one of the extra jump-
er wires included in the box.

For help with drivers, instructions, code, etc., please visit our support page: 
 www.creationcrate.com/mood-lamp-redux      
 Password: xxxxx

Make the lamp change colors faster!

Create another variable to control how dark it needs to be for the lamp to turn on. Call this vari-
able ambientLimit. Use this variable to replace the 200 in the   if(ambientLight > 200) line. Hint: 
You will have to declare this variable as an int. The value can range from 0-1024.

Now, make the Light Dependent Resistor control how fast the lamp changes colors. 

Hint: You’ll need to update the pulseSpeed variable in the loop().

Monthly challenge

Exercises

Still Need Help?  
Visit https://www.creationcrate.com/contact-us 

Sneak Peek
Can you guess what next month’s project is?
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Notes
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